Windows 7 Tips, Tricks and Secrets

Problem Steps Recorder

Frustrated trying to describe what issues you are having to the Call Center? Microsoft feels your pain, and Windows 7 includes an excellent new solution in the Problem Steps Recorder.

When any app starts misbehaving under Windows 7 then all you need do is click Start, type PSR and press Enter, then click Start Record. Then work through whatever your when you start having issues and the Problem Steps Recorder will record every click and keypress, take screen grabs, and package everything up into a single zipped MHTML file when you're finished, ready for emailing to the Call Center. It's quick, easy and effective, and will save everyone hours of troubleshooting time.

Calculate more

At first glance the Windows 7 calculator looks just like Vista's version, but explore the Mode menu and you'll see powerful new Statistics and Programmer views. And if you're clueless about bitwise manipulation, then try the Options menu instead. This offers many different unit conversions (length, weight, volume and more), date calculations (how many days between two dates?), and spreadsheet-type templates to help you calculate vehicle mileage, mortgage rates and more.

Don't take any Windows 7 applet at face value, then - there are some very powerful new features hidden in the background. Be sure to explore every option in all Windows applets to ensure you don't miss anything important.
The new Calculator is packed with useful features and functionality

Switch to a projector

Windows 7 now provides a standard way to switch your display from one monitor to another, or a projector - just press Win+P or run DisplaySwitch.exe and choose your preferred display. (This will have no effect if you've only one display connected.)

Get a power efficiency report

If you have a laptop, you can use the efficiency calculator to get Windows 7 to generate loads of useful information about its power consumption. Used in the right way, this can help you make huge gains in terms of battery life and performance. To do this you must open a command prompt as an administrator by typing 'cmd' in Start Search, and when the cmd icon appears, right-click it and choose Run as administrator.

Then at the command line, just type in 'powercfg -energy' (without quotes) and hit Return, and Windows 7 will scan your system looking for ways to improve power efficiency. It will then publish the results in an HTML file, usually in the System32 folder. Just follow the path it gives you to find your report.

Understanding System Restore

Using System Restore in previous versions of Windows has been something of a gamble. There's no way of telling which applications or drivers it might affect - you just have to try it and see.

Windows 7 is different. Right-click Computer, select Properties > System Protection > System Restore > Next, and choose the restore point you'd like to use. Click the new button to 'Scan for affected programs' and Windows will tell you which (if any) programs and drivers will be deleted or recovered by selecting this restore point.

Easily set screen resolution
Choosing a new screen resolution used to involve locating and browsing through the Display Properties applet. Windows 7 made this far simpler, though - just right-click an empty part of the desktop, select Screen Resolution and you'll immediately see the appropriate options.

Activate XP mode

If you've got old but important software that no longer runs under Windows 7, then you could try using XP Mode, a virtual copy of XP that runs in a window on your Windows 7 desktop. This only works with Windows 7 Professional, Enterprise, or Ultimate. And your system will need to have hardware virtualization (AMD-V or Intel VT) built in and turned on.

Recover locked-up apps

If an application locks up under a previous version of Windows then there was nothing you could do about it. A new Windows 7 option, however, can not only explain the problem, but may get your program working again without any loss of data.

When the lockup occurs, click Start, type RESMON and click the RESMON.EXE link to launch the Resource Monitor.

Find your frozen process in the CPU pane (it should be highlighted in red), right-click it and select Analyze Wait Chain.

If you see at least two processes in the list, then the lowest, at the end of the tree, is the one holding up your program. If it's not a vital Windows component, or anything else critical, then save any work in other open applications, check the box next to this process, click End Process, and your locked-up program will often spring back to life.

Control devices and printers
Device Manager is a powerful tool for managing hardware, but it's also rather technical and intimidating, which is probably why Windows 7 has introduced a more basic alternative in the Devices and Printers applet.

The first improvement is purely visual, with lengthy and cryptic device names replaced by large icons for major hardware items only (monitor, mouse, hard drive, printer and so on).

The new applet can also save you time, though, by providing a quick and easy way to access relevant functions for each device. If you've got some printer-related issue, say, right-clicking your printer icon displays a list of useful options - See What's Printing, Printer Preferences, Printer Properties, Delete Printer Queue and more - and all you have to do is select whatever you need.

**Automatically switch your default printer**

Windows 7's location-aware printing allows the operating system to automatically switch your default printer as you move from one network to another.

To set this up, first click Start, type Devices, and click the Devices and Printers link.

Select a printer and click Manage Default Printers (this is only visible on a mobile device, like a laptop - you won't see it on a PC).

Choose the Change My Default Printer When I Change Networks option, select a network, the default printer you'd like to use, and click Add.

Repeat the process for other networks available, and pick a default printer for each one.

And now, as you connect to a new network, Windows 7 will check this list and set the default printer to the one that you've defined.

**Right-click everything**

At first glance Windows 7 bears a striking resemblance to Vista, but there's an easy way to begin spotting the differences - just right-click things.

Right-click an empty part of the desktop, for instance, and you'll find a menu entry to set your screen resolution. No need to go browsing through the display settings any more.

Right-click the Explorer icon on the taskbar for speedy access to common system folders: Documents, Pictures, the Windows folder, and more.

And if you don't plan on using Internet Explorer then you probably won't want its icon permanently displayed on the taskbar. Right-click the icon, select 'Unpin this program from the taskbar', then go install Firefox, instead.
Display the old taskbar button context menu

Right-click a taskbar button, though, and you'll now see its jumplist menu. That's a useful new feature, but not much help if you want to access the minimize, maximize, or move options that used to be available. Fortunately there's an easy way to get the old context menu back - just hold down Shift as you right-click the taskbar button.

Desktop slideshow

Windows 7 comes with some very attractive new wallpapers, and it's not always easy to decide which one you like the best. So why not let choose a few, and let Windows display them all in a desktop slideshow? Right-click an empty part of the desktop, select Personalize > Desktop Background, then hold down Ctrl as you click on the images you like. Choose how often you'd like the images to be changed (anything from daily to once every 10 seconds), select Shuffle if you'd like the backgrounds to appear in a random order, then click Save Changes and enjoy the show.

Select multiple background images and Windows will cycle through them

Disable Windows Features

Windows 7 enables you to remove many more Windows features than ever before: Internet Explorer, Media Player, Windows Search, its indexing service, Windows Gadgets and more. This is something that you need to do cautiously, if at all (since removing something like Media Player will break many programs which rely on it), but can be useful if you're looking to create a very simple, slimmed-down system.

Click Start, type OptionalFeatures and press Enter to launch the Windows Features dialog. Clear the checkbox to the left of any features that are surplus to requirements, and click OK to remove them.
Recover screen space

The new Windows 7 taskbar acts as one big quick launch toolbar that can hold whatever program shortcuts you like (just right-click one and select Pin To Taskbar). And that's fine, except it does consume a little more screen real estate than we'd like. Shrink it to a more manageable size by right-clicking the Start orb, then Properties > Taskbar > Use small icons > OK.

Make text easier to read

Equipping your PC with an ultra high resolution displays sounds like a great idea, but it can mean text becomes very small, and as a result some people manually reduce their screen resolution to compensate. Unfortunately this then introduces another problem: if you run LCDs below their native resolution then text (and other objects) will inevitably become fuzzy.

The solution? Leave your LCD at its maximum resolution, but scale text and other objects up so they become easier to read, while also remaining sharp. You could do this in Vista, but Windows 7 now makes the process even easier. Click Start, type "DPIScaling" and press Enter, select the size increase you need - 125% or 150% - then click Apply and restart to see the results.

![Image](image_url)

Resizing your text can make it sharper and easier to read

Enjoy a retro taskbar

Windows 7 now combines taskbar buttons in a way that saves space, but also makes it more difficult to tell at a glance whether an icon represents a running application or a shortcut. If you prefer a more traditional approach, then right-click the taskbar, select Properties, and set Taskbar Buttons to Combine When Taskbar is Full. You'll now get a clear and separate button for each running application, making them much easier to identify.
Restore the Quick Launch Toolbar

If you're unhappy with the new taskbar, even after shrinking it, then it only takes a moment to restore the old Quick Launch Toolbar.

Right-click the taskbar, choose Toolbars > New Toolbar, type "%UserProfile%\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch" (less the quotes) into the Folder box and click Select Folder.

Now right-click the taskbar, clear 'Lock the taskbar', and you should see the Quick Launch toolbar, probably to the right. Right-click its divider, clear Show Text and Show Title to minimise the space it takes up. Complete the job by right-clicking the bar and selecting View > Small Icons for the true retro look.

Custom power switch

By default, Windows 7 displays a plain text 'Shut down' button on the Start menu, but it only takes a moment to change this action to something else. If you reboot your PC a few times every day then that might make more sense as a default action: right-click the Start orb, select Properties and set the 'Power boot action' to 'Restart' to make it happen.

Auto arrange your desktop

If your Windows 7 desktop has icons scattered everywhere then you could right-click it and select View > Auto arrange, just as in Vista. But a simpler solution is just to press and hold down F5, and Windows will automatically arrange its icons for you.

Browse your tasks

If you prefer the keyboard over the mouse, you will love browsing the taskbar using this nifty shortcut. Press Windows and T, and you move the focus to the left-most icon on the taskbar. Then use your arrow keys to change the focus to other icons, and you get a live preview of every window.

Display your drives

Click Computer in Windows 7 and you might see a strange lack of drives, but don't panic, it's just Microsoft trying to be helpful: drives like memory card readers are no longer displayed if they're empty. We think it's an improvement, but if you disagree then it's easy to get your empty drives back. Launch Explorer, click Tools > Folder Options > View and clear 'Hide empty drives in the computer folder'.

See more detail

The new and improved Windows 7 magnifier offers a much easier way to zoom in on any area of the screen. Launch it and you can now define a scale factor and docking position, and once activated it can track your keyboard focus around the screen. Press Tab as you move around a dialog box, say, and it'll automatically zoom in on the currently active control.
Extend your Jumplists

By default a jumplist will display up to 10 items, but it can often be useful to extend this and add a few more. Right-click Start, select Properties > Customize and set Number of Recent Items to Display in Jump Lists to the figure you need.

Disable Aero Peek

Hover your mouse cursor over the bottom right hand corner of the screen and Windows 7 will hide open windows, showing you the desktop. Seems like a good idea to us, but if the feature gets in your way then it's easy to turn off. Simply right-click the Start orb, select Properties > Taskbar and clear the box marked Use Aero Peek to Preview the Desktop.

Pin a drive to the taskbar

The taskbar isn't just for apps and documents. With just a few seconds work you can pin drive icons there, too.

Right-click an empty part of the desktop, select New > Text File, and rename the file to drive.exe. Drag and drop this onto your taskbar, then delete the original file.

Right-click your new "drive.exe" taskbar button, then right-click its file name and select Properties. Change the contents of both the Target and Start In boxes to point at the drive or folder of your choice, perhaps click Change Icon to choose an appropriate drive icon, and you're done - that drive or folder is now available at a click.

Use Sticky Notes

The Sticky Notes app is both simpler and more useful in Windows 7. Launch StikyNot.exe and you can type notes at the keyboard; right-click a note to change its colour; click the + sign on the note title bar to add another note; and click a note and press Alt + 4 to close the note windows (your notes are automatically saved).

Open folder in new process

By default Windows 7 opens folders in the same process. This saves system resources, but means one folder crash can bring down the entire shell. If your system seems unstable, or you're doing something in Explorer that regularly seems to cause crashes, then open Computer, hold down Shift, right-click on your drive and select Open in New Process. The folder will now be launched in a separate process, and so a crash is less likely to affect anything else.
Preview fonts

Open the Fonts window in Windows XP and Vista and you'll see the font names, probably with icons to tell you whether they're TrueType or OpenType, but that's about it. Windows 7 sees some useful font-related improvements.

Open the new fonts window and you'll find a little preview for every font, giving you a quick idea of how they're going to look.

The tedium of scrolling through multiple entries for each family, like Times New Roman, Times New Roman Bold, Times New Roman Bold Italic and so on, has finally ended. There's now just a single entry for each font (though you can still see all other members of the family).

And there's a new OpenType font, Gabriola, added to the mix. It's an attractive script font, well worth a try the next time you need a stylish document that stands out from the crowd.

New WordPad formats

By default WordPad will save documents in Rich Text Format, just as before. But browse the Save As Format list and you'll see you can also save (or open, actually) files in the Office 2007 .docx or OpenDocument .odt formats.

Protect your data

USB flash drives are convenient, portable, and very easy to lose. Which is a problem, especially if they're carrying sensitive data. Fortunately Windows 7 Ultimate and Enterprise have the solution: encrypt your documents with an extension of Microsoft's BitLocker technology, and only someone with the password will be able to access it. Right-click your USB flash drive, select Turn on BitLocker and follow the instructions to protect your private files.

Your USB flash drives can easily be encrypted with BitLocker

The Arkansas Cooperative Extension Service offers its programs to all eligible persons regardless of race, color, sex, gender identity, sexual orientation, national origin, religion, age, disability, marital or veteran status, genetic information, or any other legally protected status, and is an Affirmative Action/Equal Opportunity Employer.
Minimize quickly with shake

If you have multiple windows open on your desktop and things are getting too cluttered, it used to be a time-consuming process to close them all down. In Windows 7 you can use the Aero Shake feature to minimize everything in seconds, using a cool mouse gesture. Grab the title bar of the window you wish to keep open and give it a shake, and rejoice in a clear desktop area.

Configure your favorite music

The Windows 7 Media Centre now comes with an option to play your favorite music, which by default creates a changing list of songs based on your ratings, how often you play them, and when they were added (it's assumed you'll prefer songs you've added in the last 30 days). If this doesn't work then you can tweak how Media Centre decides what a favorite tune is- click Tasks > Settings > Music > Favorite Music and configure the program to suit your needs.

Customize System Restore

There was very little you could do to configure System Restore in Vista, but Windows 7 improves the situation with a couple of useful setup options.

Click the Start orb, right-click Computer and select Properties > System Protection > Configure, and set the Max Usage value to a size that suits your needs (larger to hold more restore points, smaller to save disk space).

Run As

Hold down Shift, right-click any program shortcut, and you'll see an option to run the program as a different user, handy if you're logged in to the kids' limited account and need to run something with higher privileges. This isn't really a new feature - Windows XP had a Run As option that did the same thing - but Microsoft stripped it out of Vista, so it's good to see it's had a change of heart.

Tweak PC volume

By default Windows 7 will now automatically reduce the volume of your PC's sounds whenever it detects you're making or receiving PC-based phone calls. If this proves annoying (or maybe you'd like it to turn off other sounds altogether) then you can easily change the settings accordingly. Just right-click the speaker icon in your taskbar, select Sounds > Communications, and tell Windows what you'd like it to do.

Rearrange the system tray

With Windows 7 we finally see system tray icons behave in a similar way to everything else on the taskbar. So if you want to rearrange them, then go right ahead, just drag and drop them into the order you like. You can even move important icons outside of the tray, drop them onto the desktop, then put them back when you no longer need to keep an eye on them.
Extend your battery life

Windows 7 includes new power options that will help to improve your notebook's battery life. To see them, click Start, type Power Options and click the Power Options link, then click Change Plan Settings for your current plan and select Change Advanced Settings. Expand Multimedia Settings, for instance, and you'll see a new Playing Video setting that can be set to optimize power savings rather than performance. Browse through the other settings and ensure they're set up to suit your needs.

Reorganize the taskbar

Windows 7 taskbar buttons are now movable - feel free to drag, drop and otherwise reorganize them to suit your needs. And then remember that each button can be launched by holding with the Windows key and pressing 1 to activate the first, 2 the second and so on, up to 0 for the tenth.

Search Control Panel

Navigating the Control Panel has never been the easiest of processes, however Windows 7 has tried to improve the situation by equipping the Control Panel window with its own search box. And, just as you might think, if you enter part of an applet name - "Display", say - then matching applets will be listed right away.

You don't have to be quite so specific about what you type, though, because Search generally does a very good job of figuring out what's relevant. Entering "hacker" displays the Firewall applet, for instance, while typing "virus" provides a link to Windows Defender. It's all very helpful, but keep in mind that you don't have to launch Control Panel to get these results: simply type your key words into the Start Menu search box and the same links will appear.

Repair libraries

Windows 7's new Libraries are a great way to simplify file management, when they're all working properly. Unfortunately, if their settings become damaged then they might not always display the files you expect, or you might not even be able to access them at all. If the problems survive a reboot then right-click the Libraries folder, select Restore Default Libraries, and your system should be back in full working order. (You'll lose any library customizations you made, though, so try this only as a last resort.)

Hide unused libraries

If you don't use some Windows 7 libraries then it's generally a good idea to hide them, since this recovers valuable space in the left-hand Explorer navigation pane and cuts down on scrolling. Just right-click an unwanted library and select Don't Show in Navigation Pane to hide it. To bring it back, click Libraries, right-click whatever you need and choose Show in Navigation Pane.
Find bottlenecks

From what we've seen so far Windows 7 is already performing better than Vista, but if your PC seems sluggish then it's now much easier to uncover the bottleneck. Click Start, type RESMON and press Enter to launch the Resource Monitor, then click the CPU, Memory, Disk or Network tabs. Windows 7 will immediately show which processes are hogging the most system resources.

The CPU view is particularly useful, and provides something like a more powerful version of Task Manager. If a program has locked up, for example, then right-click its name in the list and select Analyze Process. Windows will then try to tell you why it's hanging - the program might be waiting for another process, perhaps - which could give you the information you need to fix the problem.

![Resource Monitor](image)

Resource monitor keeps a careful eye on exactly how your PC is being used

Drag and drop to the command line

When working at the command line you'll often need to access files, which usually means typing lengthy paths and hoping you've got them right. But Windows 7 offers an easier way. Simply drag and drop the file onto your command window and the full path will appear, complete with quotes and ready to be used.

This feature isn't entirely new: you could do this in Windows XP, too, but drag and drop support disappeared in Vista. There does seem to be a new Windows 7 complication, though, in that it only seems to work when you open the command prompt as a regular user. Run cmd.exe as an administrator and, while it accepts dropped files, the path doesn't appear.
Customize your Jumplists

Right-click an icon on your taskbar, perhaps Notepad, and you'll see a jumplist menu that provides easy access to the documents you've been working on recently. But maybe there's another document that you'd like to be always available? Then drag and drop it onto the taskbar icon, and it'll be pinned to the top of the jumplist for easier access. Click the pin to the right of the file name, or right-click it and select Unpin From This List when you need to remove it.

Faster program launches

If you've launched one instance of a program but want to start another, then don't work your way back through the Start menu. It's much quicker to just hold down Shift and click on the program's icon (or middle-click it), and Windows 7 will start a new instance for you.

Load IE faster

Some Internet Explorer add-ons can take a while to start, dragging down the browser's performance, but at least IE can now point a finger at the worst resource hogs. Click Tools > Manage Add-ons, check the Load Time in the right-hand column, and you'll immediately see which browser extensions are slowing you down.

An Alt+Tab alternative

You want to access one of the five Explorer windows you have open, but there are so many other programs running that Alt+Tab makes it hard to pick out what you need. The solution? Hold down the Ctrl key while you click on the Explorer icon. Windows 7 will then cycle through the Explorer windows only, a much quicker way to locate the right one. And of course this works with any application that has multiple windows open.

Fix Explorer

The Windows 7 Explorer has a couple of potential annoyances. Launching Computer will no longer display system folders like Control Panel or Recycle Bin, for instance. And if you're drilling down through a complicated folder structure in the right-hand pane of Explorer, the left-hand tree won't always expand to follow what you're doing, which can make it more difficult to see exactly where you are. Fortunately there's a quick fix: click Organize > Folder and Search Options, check Show All Folders and Automatically Expand To Current Folder, and click OK.

Faster file handing

If you hold down Shift while right-clicking a file in Explorer, then you'll find the Send To file now includes all your main user folders: Contacts, Documents, Downloads, Music and more. Choose any of these and your file will be moved there immediately.

Create folder favorites

The Arkansas Cooperative Extension Service offers its programs to all eligible persons regardless of race, color, sex, gender identity, sexual orientation, national origin, religion, age, disability, marital or veteran status, genetic information, status, and is an Affirmative Action/Equal Opportunity Employer.
If you're regularly working on the same folder in Explorer then select it in the right-hand page, right-click Favorites on the left-hand menu, and select Add to Favorites. It'll then appear at the bottom of the favorites list for easy one-click access later.

Create a new folder shortcut

When you need to create a new folder in Windows 7 Explorer, don't reach for the mouse. Just press Ctrl+Shift+N to create the folder in the active Explorer window, then type its name as usual.

Open a Jumplist

Most people right-click a Windows taskbar icon to view its jumplist. You can also hold the left mouse button over the icon, though, then drag upwards to reveal the jumplist and choose the option you need, a more natural action that should be just a little faster.

Search quickly

If you'd like to search for something in an Explorer window then there's no need to use the mouse. Simply press [F3] to move the focus to the search box, enter your keyword and press [Enter] to run the search.

Search file contents

There's no obvious way in the Windows interface to search the contents of files that haven't been indexed, but all you need to do is start your search with the "content:" search filter. So entering "content:Microsoft", for instance, will find all documents (whether they're actually indexed or not) that contain the word Microsoft.

Close in a click

Hover your mouse cursor over a Windows taskbar button to display a preview thumbnail of that application window. You don't need that app anymore? Then click the small red x to close it down.

Move your taskbar

Did you know that you can move the taskbar to the top, right, or left sides of your screen? Just click on it and drag it where you want it. If it doesn’t move then right click it to check if Lock the Taskbar is checked. If so, uncheck till you get it where you want it.
Customize your clocks

Have friends, family, and colleagues in different time zones across the world? Add clocks to your taskbar to keep track of the time in their area. Or add a clock gadget to your desktop. You can even choose from eight different clock designs. Here's how to add and personalize gadgets.

Preview your files

Another great time saver is the file preview pane within a folder or library. Use it to see a file's contents without opening the file in a program. You can open the preview pane in a window by pressing Alt+P. Items such as photos and PDF files will be previewed in this area when you click them.
Help reduce eye strain with ClearType

ClearType is a tool that improves the readability of the text on your LCD screen. So if you feel the text isn't displaying sharply, use ClearType. The tool will take you through a series of screens, much like an eye exam, to help you achieve the sharpest text possible.

Get to know the new Paint

This classic Windows software has been improved in Windows 7 with new brush effects such as watercolor, crayon, and calligraphy. Paint now comes with an easy-to-use ribbon for all the cool features that you use the most. And with a touchscreen you can finger-paint, including using two fingers to create separate brush strokes simultaneously.
Pin Control Panel to the Taskbar

You cannot pin the Control Panel to the taskbar via the Start Menu or by drag and drop. Open the Control Panel and right-click its taskbar icon to pin it to the taskbar. An advantage of this is that Control Panel’s Jump List allows quick access to recently used functions.

Create Keyboard Shortcuts for Programs

You can create keyboard shortcuts for any program in Windows 7. Right-click the program icon and select Properties. Select the Shortcut tab, click in Shortcut key, to set the keyboard shortcut for that program.

Open Command Prompt in Any Folder

Like the command prompt? Miss the “Open Command Window Here’ Windows XP power toy? Press ‘Shift’ when right-clicking on a folder to get that option in the context menu. This also works on the desktop. No power toy required!
Customize the Power Button

If you restart your computer more often than you shut it down, change the default Shutdown power button to Restart. Right-click on Start, select Properties, and choose the Power button action that you use the most.

Undo an Accidental File Move or Deletion With the Keyboard

Have you ever tried to select a bunch of files while holding the Ctrl key, and then accidentally copied all of them because you slightly moved your mouse? Maybe you just deleted a file and don't feel like hunting it down in the Recycle bin. In either case, you can use the Ctrl+Z shortcut key to immediately reverse whatever you didn't mean to do.

Create a Zip File with the Same Name as a Selected File

If you regularly use the built-in Send To → Compressed (zipped) folder feature to create zip files in Windows, you might notice that it seems to randomly pick a filename for the generated file. If you want to save the step of renaming the file, you can make sure that you right-click on top of the file that you want to have the same name.

For instance, if we had right-clicked on the Readme.txt file in the screenshot and used the Send To → Compressed feature, the resulting file would have been called Readme.zip. Since that's not very helpful, it's better to right-click on one of the selected HTGBack.x files, which will give us HTGBack.zip instead.